
PyramidChart
Software: Microsoft Excel

Data:

Steps:
1. Change the  

first column to  
negative values

2. Select table

3. Insert > Bar > Clustered Bar

12. On the “Chart Tools” header, select the “Layout” Tab  
and click on the “Legend” drop down

13. Select “Show Legend at Bottom”

14. Right click in the whitespace of the chart

15. Select “Select Data”

16. In the “Legend Entries (Series)”  
section, select the bottom label  
and click on the Up arrow to  
reorder the legend entries

17. Click on the Chart Tools header > Format tab

18. With the left bars selected change the  
“Shape Outline” to black

19. Select the right bars and change the  
“Shape Outline” to black

20. Right click on the bottom axis > in the  
“Minimum” click on “Fixed” and set to -100

21. In the “Maximum” click on “Fixed” and set to 100

22. Click on “Number” on the left side of the  
Format Axis Dialogue Box

23. Select “Custom” and enter “0;0” and then click  
on “Add”

4. Right click on the “Axis” in the centre of the graph and select 
“Format Axis”

5. In the “Major tick mark type:” select “None“

6. In the “Axis labels” section select “Low”

7. Close the dialogue box 

8. Right click on a bar > select “Format Data Series”

9. Change the “Series Overlap” to “Overlapped”

10. Change “Gap Width” to “No Gap”

11. Delete the Legend
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SloPeChart
Software: Microsoft Excel

Data:

Steps:
1. Select the table
2. Insert  > “Line” > “Line” 

5. Delete the  
“horizontal lines” 

6. Delete the vertical axis 
and the legend

7. Make the chart  
 narrower and longer

8. Right click on a line  
and click on  
“Add Data Labels”

9. Click on the data label 
and change  
the color to the  
same color as  
the line

10. Repeat for all the lines

11. Left click and then 
right click on a  
label to the left > 
select “Format  
Data Label”

12. In the Label  
Position click  
on “Left”

13. Repeat for  
all the lines

14. Left click on the right 
label twice then right 
click on on the right  
label and select  
“Format Data  Label”

15. Select “Right” in the “Label Position” section

16. Repeat for all lines

3. Right click in the white space of the chart  
and select “Select Data” 

4. Click on the “Switch Row/Column” button
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SPeedometerChart
Software: Microsoft Excel

Data:

Steps:
1. In the cell beside the label “End”, enter the 

following formula: =200-SUM(E2:E3)

2. Select the “Speedometer Segment” table

3. Insert > “Other Charts” > “Doughnut” 

10. Right click in the white area of the chart > Select “Select Data”

11. In the “Legend Entries (Series)” section click on “Add”

4. Right click on the Doughnut > Select “Format Data Series” 

5. In the “Angle of first slice” section, enter “270”

18. Click on the bottom half of the Pie Chart > Fill > No Fill

19. Click on the top third of the Pie Char > Fill > No Fill

20. Click on the remaining sliver > Fill > Black

21. Right click on the black sliver > Add Data Label

22. Click on the Data Label and in the formula box type “=”  
and click on the number beside the “Needle Value” cell

6. Select the bottom half of the doughnut

7. Click on “Fill” > select “No Fill”

8. Select the each segment and change the “Fill” to “Solid Fill”  
using the colors red, orange, yellow and green.

9. Delete the Legend

12. In the “Series values” section, delete the text in the box >  
click on the           button to the right

13. Select the three numbers in your Meter table >  
press “Enter”> click on “OK”

14. Right click on the new  
doughnut > click on  
“Change Series Chart Type” 

15. Select the Pie Chart >  
click on “OK”

16. Right click on the Pie Chart > 
”Format Data Series” > Change 
the Rotation to “270”

17. Click on “Secondary Access”
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thermometerChart
Software: Microsoft Excel

Data:

Steps:
1. Select the table

2. Insert > Column > Clustered Column

7. Click on the “Boys” column

8. In the “Plot Series On” dialogue box, click on “Secondary Axis”

9. Change the “Gap Width” to “200%”
*NOTE: The bar you have selected when you click on “Secondary Axis” will be 
the bar that is at the front.  

10. Select and Delete the axis on the right of the chart

11. Clean up the chart:  Delete horizontal lines, change the scale 
of the left axis to 100%, change the axis font colors to grey, 
add data labels (white) on the “inside end” of the column for 
boys and (black) on the “outside end” of the column for girls.

3. Right click on the  
“Boys” column >  
Select “Format  
Data Series” 

4. Change “Gap Width”  
to “100%”

5. Click on the “Girls” column

6. Click on “Fill” > Solid Fill >  
Set Transparency to “70%”
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SankeyChart
Software: Microsoft Excel

Steps:
Create a table with 1-50 columns and copy across 4 rows Delete the horizontal lines

Here the labels on the x axis refer to each row in the table.

In the table, delete all the cells containing values from 1 to 14  
and from 35 to 50. This will make the lines appear to float in the 
chart area.

In row 4 and 5, add the values from 7 to 11 back in but leave the 12 
to 14 blank. This makes a new section floating in the chart area.

Select the table and create a line chart

Select Data—Switch rows to column
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Select the block you just created and move it to the values 15 to 
19 in the table.

Extend the values from row 4 and 5 out from 34 to 41. Delete 
values 35 and 36. Select the new block and move it to replace 
values 30 to 34 in rows 4,5

Delete the legend and the horizontal and vertical axis.

Select each line in the bundle and change each line to the  
same color.

Change the thickness of each line in the bundle to 5.5 pts.  

Change cap type to square for each line in the bundles



interactive/dynamicCharts
Software: Microsoft Excel

10. Finish this new table by adding labels by copying and  
pasting the column labels, from the first row, above the row 
of offset formulae

11. Select this new 2-row table and use it to create a graph:

1. Click on “Developer” 
Note: If you do not see Developer, right click on the ribbon > Select Customize 
ribbon > Put a checkmark beside “Developer”

2. In the Controls section of the ribbon click on “Insert” >  
Click on Combo Box (Form Control)

3. Right click on the combo box and click on “Format Control” > 
Click on the “Control” tab

4. Click on the button beside the “Input range:” and select the 
first column of labels in your table and then press enter.  
These are the labels that will appear in your drop down box

5. Click on “Cell link” and select a cell below the combo box and 
press enter. This cell will show (as a number) which entry has 
been select from the combo box.

Data:

Steps:
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6. The “Drop down lines” determines how many labels will be  

displayed at one time when the combo box is used. The 
default is 8 but you can change it to as many or as few as you 
would like. Once you have decided on the number of labels to 
show press enter

7. Below the combo box we will create a table consisting of  
2 rows. In the first cell enter “=” and enter the following  
formula: =offset(A1,A13,0) 

This formula uses 2 cell references. The first, A1 refers to the 
cell above your first piece of data (usually a label). The second 
reference is for the cell that returns the combo box selection. 
Hit enter when you have completed the formula

8. Click on the cell with the offset formula you just created, 
and then go into the formula and add a $ infront of the 
A and a $ infront of the 13 in the second cell reference: 
=offset(A1,$A$13,0) 

This will freeze the cell so when it is copied, in the next step, 
the cell reference stays on the combo box value.

9. Copy and paste this offset formula  across the table:



12. Note that as you change the combo box selection,  
the columns and titles in the graph automatically update  
as well.

13. To make the graph more presentable for sharing or present-
ing, right click on the graph and select “Move Chart” and 
select “New sheet”

14. Now add in a combo box so the graph can be updated:

a. Click on “Developer” 

b. In the Controls section of the ribbon click on “Insert” > 
Click on Combo Box (Form Control)  

c. Right click on the combo box and click on “Format  
Control” > Click on the “Control” tab

d. Click on the button beside the “Input range:”, click on 
“Sheet1” where your table is, and select the first column 
of labels in your table and then press enter. These are the 
labels that will appear in your drop down box

e. Click on “Cell link”, click on “Sheet1” and select a cell 
below the combo box and press enter.  

f. The “Drop down lines” determines how many labels will 
be displayed at one time when the combo box is used.  
The default is 8 but you can change it to as many or as 
few as you would like.  Once you have decided on the 
number of labels to show press enter

g. Click on “Ok”



  
 
 
 

 

  
Color Brewer: Selecting color palettes for data 
 
Web app: http://colorbrewer2.org 
 
 
 
 
 
 
 
 

 

  
Kuler: Exploring and Saving Your Color Palettes 
 
Web app: http://kuler.adobe.com 
 
 
 
 
 
 
 
 
 

 

  
ArcGIS Online:  Online GIS  
 
Web app: https://www.arcgis.com/home/ 
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Parallel Sets: Categorical Data Visualization 
 
Download: http://code.google.com/p/parsets/downloads/list 
 
 
 
 
 
 
 

 

  
Dex: Javascript Visualization Libraries Without 
the Coding 
 
Download: http://www.javainc.com/projects/dex/ 
 
 
 

 

  
Quantum GIS (QGIS): Open Source GIS  
 
Download: http://hub.qgis.org/projects/quantum-
gis/wiki/Download 
 
Note: the more interesting visualizations like cartograms and 
kernel density rasters can be accessed in QGIS through 
GRASS plugins 
 

 

 

 

B FREESOFTWARE 
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Bar graph – categorical variable 
 
Package: ggplot2 
 
Syntax: 
 
 library (ggplot2) 

      This first line loads the package ggplot2 
 

 qplot(race, data=census) 
      This second plots the chart using race data from the census data table.  

 

 
Histogram – continuous variable 
 
Package: ggplot2 
 
Syntax: 
 
 library (ggplot2) 

      This first line loads the package ggplot2 
 

 qplot(mark, data=census) 
      This second line plots the chart using mark data from the census data table.  

 
 

 
Histogram – continuous variable, small multiples  
 
Package: ggplot2 
 
Syntax: 
 
 library (ggplot2) 

      This first line loads the package ggplot2 
 

 qplot(mark, data=census, facets = progress ~ .)) 
      This second line plots the chart using mark data from the census data table and creates multiple charts 
      based on the progress variable.  

 
  

C RSYNTAX 



  
 
 
 

 

 
 

 
Plotting a Continuous variable on a Categorical Variable with jitter 
Package: ggplot2 
 
Syntax: 
 
 library (ggplot2) 

      This first line loads the package ggplot2  
 

 qplot(progress, mark, data=census, geom=”jitter”) 
      This second line plots the chart using progress data by mark data and introduces small variations  
      to each point.   

 
 

 
Density Curve – with transparency 
 
Package: ggplot2  
 
Syntax: 
 
 library (ggplot2) 

      This first line loads the package ggplot2  
 

 qplot(mark, data=census, fill=progress, geom=”density”, alpha=I(0.5)) 
      This second line plots the marks from the census table for each progress value as a separate density curve 
       with transparency so you can see how the curves overlap.  

 

 
Euler Diagram 
 
Package: venneuler 
 
Syntax: 
 library (venneuler) 

      This first line loads the package venneuer 
 

 
 vd <- venneuler (c(A=8.5, B=16.9, C=2.3, “A&B” = 8.2, “A&C”=0.9, “B&C”=6.3, “A&B&C”=5.4)) 

      This second line describes three circles A, B and C and describes how large each intersecting segment is.  
      The size of the circles and segments will be called vd (for venn diagram but you can use any label you  
       would like) 
 

 plot(vd) 
      This third line draws the three circles you have defined  

 
 

C RSYNTAX 




